package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\(.*\)`)
var str = `Фицджеральд, Фрэнсис Скотт
Экман П.
Мазаник, Таисия Михайловна, Далидович, Анастасия , Цивилько, Надежда Михайловна
Беляева Т.И., отв. ред.
Сафарли, Эльчин
Колесникова, Елена Владимировна
Несбё, Ю
Плешаков, Андрей Анатольевич
Брубейкер Э.
Брэдбери Р.
Маланка Татьяна Григорьевна, Прищеп Анна Александровна, Пылаева Инна Александровна
Н. М. Павлова
Пашкова Л.
Егорова А. А.
Созонова, Надежда Николаевна, Куцина, Екатерина Владимировна
Е. М. Зорина, М. В. Зорин
Т. Г. Николенко, И. И. Кошманова
Токаева Т. Э., Кустова Л.Б.
Лутцева Е. А.
Дорофеев Г., Седова Е., Шестаков С., Пчелинцев С.
Квактун Г.Г., Квактун И.Г.
Сизова Е.В.
С. Н. Лозовая
Кучук Оксана Владимировна
др., Тонких А.П., Козлова С.А., Демидова Т.Е.
др., Гладышева Н. Н., Губарькова Е.В., Шилова В.Н., Гнусарева И. А.
О. В. Мешкова
Голуб Ирина Борисовна
др., Моргунова А. Б.
Н. В. Дубровская
Субботина, Елена Александровна
Карпухина Наталия Александровна
Агеева И.Д.
Л. Г. Петерсон, Э. Р. Барзунова, А. А. Невретдинова
Наталья Суркова,Ольга Яровая
Аким Я.Л., Коринец Ю.И., Пришвин М.М.
Ханнанов Н., Никифоров Г., Орлов В.
др., Бибекова О. А.
Т. Н. Видеман
Ященко Иван Валерьевич, Шноль Дмитрий Эммануилович, Высоцкий Иван Ростиславович, Столбов Константин Михайлович
Смирнова И. Г.
Сергей Савушкин
Комиссарова В.
Коновалова Н., Иванов Ю., Гилев М. (авт.-сост.), Иванов М.
Курукин, Игорь Владимирович, и другие, , Шестаков, Владимир Алексеевич
Казакова Р.Г.
Бортникова Е.
Канчурина Р., БерсеневаТ., Гылка Е. и др.
Лысенко Ф., Кулабухов С. (ред.)
Большаков В.
Рид Т.М.
Воскресенская Е.О., Ткаченко Е.М., Слаутина Н.В.
Н. А. Червякова
Сертакова Н. М.
Пашкова Людмила Ивановна
Егорова Антонина Алексеевна
Зорина Е.М., Зорин М.В.
Жукова, Олеся Станиславовна
Миловидов В.
Токаева Т.Э.
Лутцева Е.А.
Дорофеев Георгий Владимирович, Шестаков Сергей Алексеевич, Седова Елена Александровна, Пчелинцев Сергей Валентинович
Квактун Галина Гиршевна, Квактун Ирина Гиршевна
Картушина М.Ю.
Лободина Н. (сост.)
Сизова Е., Харитонова Н.
Гетцель В. (ред.)
О. В. Кучук
Козлова Светлана Александровна, Демидова Тамара Евгеньевна, Тонких Александр Павлович
Гладышева Наталья Николаевна, Губарькова Елена Владимировна, Шилова Вера Николаевна
Руднева А.В.
А. Б. Моргунова, Н. В. Яковлева
Наталия Нищева
О. В. Павлова
Новоторцева Н.В.
Севостьянова Елена Олеговна
Лаврова Н.М.
Агеева И.
Пустовалова О. П., Фролова Н. Г.
Зеркальная Т.В., сост.
Ханнанов Наиль Кутдусович, Орлов Владимир Алексеевич, Никифоров Геннадий Гершкович
Бибекова О.А.
Бостельман А., Финк М.
И. Г. Смирнова
Теплюк С.Н., Савушкин С.Н.
Л. Ю. Комиссарова
Н. Г. Коновалова, Ю. П. Иванов, М. Л. Гилев`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}