using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^:\w+:(?: *:\w+:)*$";
string input = @":foo::bar:
:foo:
:foo: :bar::test:
:foo: :bar: :test:
:foo:something:bar:
:foo:something
some :bar:
:foo: some:bar: thing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}