package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(src="cid:).*?(.+?(\.gif|\.png|\.jpg))+?([^"]*)`)
var str = `bodyHtmlText:
<p class=MsoNormal><a href="http://www.centric.eu/craft"><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D;text-decoration:none'><img border=0 width=300 height=100 id="_x0000_i1026" src="cid:image001.jpg@01D2E5DE.EC0337E0" alt="cid:image002.jpg@01D19BE7.F4CB9B70"></span></a><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'> <o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><a href="https://www.facebook.com/Centric"><span style='color:blue;text-decoration:none'><img border=0 width=31 height=75 id="_x0000_i1027" src="cid:image002.jpg@01D2E5DE.EC0337E0" alt="Like ons"></span></a><span lang=EN-US style='color:#1F497D'> </span><a href="http://www.linkedin.com/company/centric"><span style='color:blue;text-decoration:none'>
USAGE:
const string patternImageFilesInBody = @"(src=""cid:).*?(.+?(\.gif|\.png|\.jpg))+?([^""]*)";
//const string patternImageFilesInBody = @"(src=""cid:).*?/?([^/]+?(\.gif|\.png|\.jpg))+?(@[^""]*)";
//const string patternImageFilesInBody = @"(src=\""cid:).*?/?([^/]+?(\.gif|\.png|\.jpg))+?(@.................)";
var bodyIndependentsoft = Regex.Replace(bodyHtmlText, patternImageFilesInBody, m => "src=\"" + tempFolder + "/" + m.Groups[2].Value + "\"");
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}