package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)f\*\*k`)
var str = `f**k
feedback
firetruck
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}