#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d*(\.\d+)?%)"
Local $sString = "Bachelor of Engineering in Electronics from in 2013 with 60%." & @CRLF & _
"Diploma (Electronics & Video Engineering) from in 2009 with 79.39%." & @CRLF & _
"SSC from in 2006 with 61.71%." & @CRLF & _
"" & @CRLF & _
"Bachelor of Engineering in Electronics from in 2013 with 60%." & @CRLF & _
"Diploma (Electronics & Video Engineering) from in 2009 with .39%." & @CRLF & _
"SSC from in 2006 with .71%."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")