# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$?(?<!\d)(?:\d{1,3}(?:,\d{3})*|\d{4,})?\.?\d+"
test_str = ("\"Transfer to Retirement Rsvs-MA FX .11\" \n"
"\"Opening Balance FX 342,536,002.63\" \n"
"\"VA 85.85\" \n"
"\"VB .00\" \n"
"\"Manual Adjustment FX 6,838.36-\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.