$re = '/(?:^|[,-] ?)(?<JOUR>J[0-9]+)\b/m';
$str = 'J1,J2, J3
J1, J2, J3 - J5, J7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);