$re = '/(Student|word|\.)/m';
$str = 'Student.name.word
Student.Age.word
Student.Profession.word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);