$re = '/^(?!00:00)(24:00|([0-1]\d|2[0-3]):[0-5]\d)$/m';
$str = '00:00
24:00
12:45
00:01
00:77
26:00
02:59
24:12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);