import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A\n"
+ " (?<major>0|[1-9]\\d*)\\.\n"
+ " (?<minor>0|[1-9]\\d*)\\.\n"
+ " (?<patch>0|[1-9]\\d*)\n"
+ " (?:\n"
+ " -(?<prerelease>\n"
+ " (?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-]*)\n"
+ " (?:\\.(?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-]*))*\n"
+ " )\n"
+ " )?\n"
+ " (?:\n"
+ " \\+(?<buildmetadata>[0-9a-zA-Z-]+(?:\\.[0-9a-zA-Z-]+)*)\n"
+ " )?\n"
+ "\\Z\n";
final String string = "1.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}