import Foundation
let pattern = #"(?s)\b[A-Z]\..*?\?(?=\h+[A-Z]\.|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A. What sort of country do the framers of the Northwest Ordinance envision for the next generation of Americans?
B. How do the statements on behalf of individual religious rights and the public support of religion compare with the statements found in the new state constitutions?
A. What explains President Lincoln’s attitude toward Louisiana in his letter to General Banks? Does his Second Inaugural Address explain his attitude? How do Lincoln, Douglass, and Stevens’ attitudes toward the South differ? Is Stevens’ constitutional argument about the basis of Reconstruction sound? If so, was that sufficient to make his approach to the seceded states sound? Do Stevens’ remarks about Jews, the Irish and others undermine his claim to be a champion of the principles of the Declaration of Independence? Was the response of Southerners as described and defended by Tillman inevitable, or could some version of restoration or reconstruction have prevented it?
B. Do the views expressed in the twentieth century differ from those expressed in the documents below? For example, compare the views of Senators Tillman and Thurmond, both Democrats from South Carolina. Did the constitutional arguments change between the 1860s and the 1960s?
C. How true does President Abraham Lincoln’s remark in his Second Inaugural Address that both Northerners and Southerners prayed to the same God and read the same Bible appear in light of the very different interpretations of said Bible on the question of slavery, as evidenced in the antebellum period?
test A.Test? B.Test?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)