$re = '/^([^:]+):.*/';
$str = '10.27.76.50:9999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);