#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(\-|)[0-9]+\.[0-9]+$|^(\-|)[0-9]+$)"
Local $sString = "100.0" & @CRLF & _
"-100.0" & @CRLF & _
"a100" & @CRLF & _
"100a.0" & @CRLF & _
"100.0a" & @CRLF & _
"-b100.a" & @CRLF & _
"-100.0s" & @CRLF & _
"100" & @CRLF & _
"-100" & @CRLF & _
"-5." & @CRLF & _
".2" & @CRLF & _
"0.2" & @CRLF & _
"-0.5" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")