$re = '/^(?:\S.*?\S|\S)$/m';
$str = 'foobar
foobar
foo bar
foobar
foo bar
f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);