re = /(\{)(.*)(\})/m
str = '{{{{{{{{{{{{{{{{{{{{Valor aqui dentro}}}}}}}}}}}}}}}}}}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end