#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S).(?!\S)"
Local $sString = "a interior Casquillo Dint.50 100" & @CRLF & _
"brg aligning Self MM161Z end rod" & @CRLF & _
"del eje4 Junta hendidura" & @CRLF & _
"352 Junta tórica .20279" & @CRLF & _
"2z/C3GJN Rodamiento" & @CRLF & _
"pos. Ser. 440PM18002 Interruptor" & @CRLF & _
"Reductor SR12013 LF de velocidad" & @CRLF & _
"Sick M40Z025023TB1 fotoeléct. Barrera" & @CRLF & _
"PR Acoplamiento SA00177" & @CRLF & _
"cable 4p Conector micro 4m 889DF4AC5" & @CRLF & _
"Brazo actuador 399 largo:" & @CRLF & _
"Rodillo 114mm palanca morro largo:" & @CRLF & _
"Rodillo 330180000 libre" & @CRLF & _
"shaft bar 351819028 Nose" & @CRLF & _
"lineal excel Nook Rodamiento" & @CRLF & _
"Fotocélula Banner" & @CRLF & _
"cable EL03926 Prox. Sensor" & @CRLF & _
"EL99942 Ventilador" & @CRLF & _
"Cilindro reparado HY00115 hidráulico" & @CRLF & _
"SR10510 Reductor velocidad de" & @CRLF & _
"barra largo Rodillo de 98mm morro" & @CRLF & _
"Rueda horno nivel de centrado" & @CRLF & _
"SENSOR:VIBRATION,IP68,500G RANGE,MAX165°" & @CRLF & _
" | XSM-3034-30-PP iglidur X sleeve bearing" & @CRLF & _
"KIT:HI-TECH,OK143521,O-RING 5/2 WAY,VLV a |" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")