# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\w+.*?\K[\w-]+=[\"']*\s*(?:\w+\s*)*[A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,}\s*(?:['\"]?(?:\w+\s*)*['\"]?)?[\"']*(?=.*?>)"
test_str = ("<br data-a1=\"nope\" attr=\" jepp@get.me \" data-a2=\"nope\">\n"
"<br data-a1=\"nope\" attr=' jepp@get.me ' data-a2=\"nope\">\n"
"<br data-a1=\"nope\" attr=jepp@get.me data-a2=\"nope\">\n"
"<br data-a1=\"nope\" attr=\" jepp@get.me \" data-a2=\"nope\"/>\n"
"<br data-a1=\"nope\" attr=\" jepp@get.me \" data-a2=\"nope\" />\n"
"<tag data-a1=\"nope\" attr=\" jepp@get.me \" data-a2=\"nope\">text</tag>\n"
"<tag data-a1=\"nope\" attr=' jepp@get.me ' data-a2=\"nope\">text</tag>\n"
"<tag data-a1=\"nope\" attr=jepp@get.me data-a2=\"nope\">text</tag>\n"
"<tag data-a1=\"nope\" attr=\" additional text jepp@get.me 'additional text'\" data-a2=\"nope\">text</tag>\n"
"<tag data-a1=\"nope\" attr=\" additional text jepp@get.me additional text\" data-a2=\"nope\">text</tag>\n"
"<tag data-a1=\"nope\" attr=' additional text jepp@get.me \"additional text\"' data-a2=\"nope\">text</tag>\n"
"<tag data-a1=\"nope\" attr=\" jepp@get.me jeppagain@get.me \" data-a2=\"nope\">text</tag>\n"
"abc dont@get.me 123 <input value=\"please@get.me\">xyz\n"
"abc dont@get.me 123 <tag1 att1=\"val1\" email1=\"please@get.me\">xyz\n"
"abc dont@get.me 123 <tag2 att1=\"val1\" email2=\"please@get.me\" att1=\"val1\">xyz\n"
"<tag2 att1=\"val1\" email3='please@get.me' att1=\"val1\">xyz\n"
"<tag2 att1=\"val1\" email4=please@get.me att1=\"val1\">xyz\n"
"<tag2 att1=\"val1\" email5=\" please@get.me \" att1=\"val1\">xyz\n"
"<tag2 att1=\"val1\" email6=' please@get.me ' att1=\"val1\">xyz\n"
"<tag data-yeah-also-valid-attr-name=\"please@get.me\">xyz\n"
"<tag data-yeah-attr=\"please@get.me\">\n"
"<tag data-yeah-attr='please@get.me'>\n"
"<tag data-yeah-attr=please@get.me>\n"
"<tag data-yeah-attr=\"'please@get.me'\">\n"
"<tag data-yeah-attr='\"please@get.me\"'>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.