using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"php";
string input = @"php
/php/gmixsuUAJD";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}