$re = '/\w+\s+(?!3\b)\d+/m';
$str = 'MyString 33
MyString 10
MyString 5
MyString 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);