using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var thumbdata = {\n(.*?);";
string input = @" sometext;
var thumbdata = {
thumbs: [{avatar: ""/i/nophoto.jpg"", username: ""IslandGirlSearching"",la:""0 second "",chatid: ""0"",userid: ""2088789"", age:""21"",city:""Cebu""},{avatar: ""/p/2021-08/Cristina266/ava-1629535964.jpg"", username: ""Cristina266"",la:""0 second "",chatid: ""0"",userid: ""2095868"", age:""26"",city:""Pasig City""} ] };
var source = sometext;";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}