$re = '/\d+,\d/';
$str = '12,3 lub 1233,4 lub 978,9 lub 21183,4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);