#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]+ ?[1-9]+[, ]*[0-9]{,2}:[0-9]{,2}[^,]+, ?T=[-0-9]+degr?"
Local $sString = "# Measurements started" & @CRLF & _
"Sep 9, 9:05, T=22deg" & @CRLF & _
"SEP 9, 10:15, T=25deg" & @CRLF & _
"# Taking a coffee break" & @CRLF & _
"Sep 9, 11:15, T=-10deg" & @CRLF & _
"# Weekend" & @CRLF & _
"Sept 12, 09:00AM, T=32deg" & @CRLF & _
"Oct12 13:00, T=32degr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")