const regex = /^\s*(?:(?:(?<A_Addition_to_address_1>.*?),\s*)?(?:No\.\s*)?(?<A_House_number_1>\p{N}+[a-zA-Z]?(?:\s*[-\/\p{P}]\s*\p{N}+[a-zA-Z]?)*)\s*,?\s*(?<A_Street_name_1>(?:[a-zA-Z]\s*|\p{N}\p{L}{2,}\s\p{L})\S[^,#]*?(?<!\s))\s*(?:(?:[,\/]|(?=#))\s*(?!\s*No\.)(?<A_Addition_to_address_2>(?!\s).*?))?|(?:(?<B_Addition_to_address_1>.*?),\s*(?=.*[,\/]))?(?!\s*No\.)(?<B_Street_name>\S\s*\S(?:[^,#](?!\b\p{N}+\s))*?(?<!\s))\s*[\/,]?\s*(?:\sNo\.)?\s+(?<B_House_number>\p{N}+\s*-?[a-zA-Z]?(?:\s*[-\/\p{P}]?\s*\p{N}+(?:\s*[-a-zA-Z])?)*|[IVXLCDM]+(?!.*\b\p{N}+\b))(?<!\s)\s*(?:(?:[,\/]|(?=#)|\s)\s*(?!\s*No\.)\s*(?<B_Addition_to_address_2>(?!\s).*?))?)\s*$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:(?:(?<A_Addition_to_address_1>.*?),\\s*)?(?:No\\.\\s*)?(?<A_House_number_1>\\p{N}+[a-zA-Z]?(?:\\s*[-\\\/\\p{P}]\\s*\\p{N}+[a-zA-Z]?)*)\\s*,?\\s*(?<A_Street_name_1>(?:[a-zA-Z]\\s*|\\p{N}\\p{L}{2,}\\s\\p{L})\\S[^,#]*?(?<!\\s))\\s*(?:(?:[,\\\/]|(?=#))\\s*(?!\\s*No\\.)(?<A_Addition_to_address_2>(?!\\s).*?))?|(?:(?<B_Addition_to_address_1>.*?),\\s*(?=.*[,\\\/]))?(?!\\s*No\\.)(?<B_Street_name>\\S\\s*\\S(?:[^,#](?!\\b\\p{N}+\\s))*?(?<!\\s))\\s*[\\\/,]?\\s*(?:\\sNo\\.)?\\s+(?<B_House_number>\\p{N}+\\s*-?[a-zA-Z]?(?:\\s*[-\\\/\\p{P}]?\\s*\\p{N}+(?:\\s*[-a-zA-Z])?)*|[IVXLCDM]+(?!.*\\b\\p{N}+\\b))(?<!\\s)\\s*(?:(?:[,\\\/]|(?=#)|\\s)\\s*(?!\\s*No\\.)\\s*(?<B_Addition_to_address_2>(?!\\s).*?))?)\\s*$', 'gmu')
const str = `109 - 111 Wharfside Street
40-42 Parkway
25b-26 Sun Street
43a Garden Walk
6/7 Marine Road
10 - 12 Acacia Ave
4513 3RD STREET CIRCLE WEST
0 1/2 Fifth Avenue
194-03 1/2 50th Avenue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}