use strict;
my $str = '02/Apr/2006
23/10/1996
13/10/2000
Right Ones
28/05/2000
01/01/2000
1/1/2000
01/Jan/2000
31/01/
31/Jan/2000
31.Jan.2000
31-Jan-2012
30/Mar/2000
29/Apr/2000
29/10/2000
29/02/2000
20/Apr/1983
28/02/2000
01/1/2000
01/Jan/2000
01/1/01
01/Jan/01
29/02/2000
29/Feb/2000
01/01/2020 #1st Jan
07/03/2020 #3 July
12/2/2020 #2 December
23/4/2020 #23 April
Wrong Ones
31/04/2000
29/Feb/2001
13/13/2000
30/Feb/2000
25/February/2000
32/01/2000
32/Jan/2000
';
my $regex = qr/^(?<Monthswith31>31(?<s1>\/|\.|-)(0?[13578]|1[02]|(Jan|Mar|May|Jul|Aug|Oct|Dec))\g<s1>(?<Year>19[0-9][0-9]|200[0-7]))$|^(?<Monthswith29or30>(29|30)(?<s2>\/|\.|-)(0?[1,3-9]|1[0-2]|(Jan|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\g<s2>(?<Year2>19[0-9][0-9]|200[0-7]))$|^(?<Allmonthswith28>(0?[1-9]|1[0-9]|2[0-8])(?<s3>\/|\.|-)(0?[1-9]|1[0-2]|(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\g<s3>(?<Year3>19[0-9][0-9]|200[0-7]))$|^(?<FebLeapYears>29(?<s4>\/|\.|-)(0?2|Feb)\g<s4>(19([02468][048]|[13579][26])|200[04]))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}