$re = '/value="(?<yourValue>.[^"]*)/m';
$str = '<input class="thatclass" style="border: 0px currentColor; border-image: none; text-align: center; font-weight: bold;" type="text" size="35" value="Ata Tata Baba [3834]">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);