import re
regex = re.compile(r"""
(?:\s*from\s(?:(?:([^\(\n]*?)\s)|(\[[^\]]*\]))?(?:\((?:(?:((?!HELO|EHLO)[^\s]*)|(?:(?:EHLO)|(?:HELO)))?(?:[\s\w\.]*(?:(?:\[([^\]]*)\])|([^\)\s]*))\))))?(?:\{.*\})?)?
\s*(?:(?:client\s)?[\(\{\[]+([^\)\}\]]*)[\)\}\]]+\;?(?:\{.*\})?)?
(?:[\s\n]*)
(?:\s*(?:by(?:(?:.*?)(?:\;|(?:[\r\n]+))))(?!.*with))?
(?:\s*(?:by\s[^\;]*\)?)(?=.*with)\s*)?
(?:with\s*(?:((?:[^\n;]*))(?:.*\;)?))?
(?:[\s\n]*)?
(?:\(?envelope-from\s*([^\n]*)\;?\)?)?
(?:\s*id[^;]*\;?)?
(?:[\s\n]*)?
(?:for\s([^\;]*)\;)?
(?:[\s\n]*)?
(?:\(.*\)\;)?(?:[\s\n])?
([^\(]+)?
(?:\(?envelope-from\s*([^\n]*)\;?\)?)?
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("from qzienfhr ([182.109.196.197]) by mail.oucu.edu.eg\n"
" with SMTP (Code-Crafters Ability Mail Server 2012);\n"
" Mon, 03 Dec 2018 12:42:56 +0200")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")