re = /(?<=^| )(?=[^. ]*\.)(?=(?:[^X ]*X){4}).{5}(?=$| )/
str = 'XX.XX XXXXX XXXX. X.X.X .XXXX ..... X..XX abc.XXXX XX.XabcX XXX.X'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end