import re
regex = re.compile(r"^(?:(?:ds|crl|ocsp|dnl\-[0,1][0-9]\.geo|(?:[sp][0,1][0-9]|downloads)\.upd)\.kaspersky|downloads[0-9]?\.kaspersky\-labs)\.com$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ds.kaspersky.com\n"
"dnl-01.geo.kaspersky.com\n"
"dnl-02.geo.kaspersky.com\n"
"dnl-03.geo.kaspersky.com\n"
"dnl-04.geo.kaspersky.com\n"
"dnl-05.geo.kaspersky.com\n"
"dnl-06.geo.kaspersky.com\n"
"dnl-07.geo.kaspersky.com\n"
"dnl-08.geo.kaspersky.com\n"
"dnl-09.geo.kaspersky.com\n"
"dnl-10.geo.kaspersky.com\n"
"dnl-11.geo.kaspersky.com\n"
"dnl-12.geo.kaspersky.com\n"
"dnl-13.geo.kaspersky.com\n"
"dnl-14.geo.kaspersky.com\n"
"dnl-15.geo.kaspersky.com\n"
"dnl-16.geo.kaspersky.com\n"
"dnl-17.geo.kaspersky.com\n"
"dnl-18.geo.kaspersky.com\n"
"dnl-19.geo.kaspersky.com\n"
"dnl-00.geo.kaspersky.com\n"
"s00.upd.kaspersky.com\n"
"s01.upd.kaspersky.com\n"
"s02.upd.kaspersky.com\n"
"s03.upd.kaspersky.com\n"
"s04.upd.kaspersky.com\n"
"s05.upd.kaspersky.com\n"
"s06.upd.kaspersky.com\n"
"s07.upd.kaspersky.com\n"
"s08.upd.kaspersky.com\n"
"s09.upd.kaspersky.com\n"
"s10.upd.kaspersky.com\n"
"s11.upd.kaspersky.com\n"
"s12.upd.kaspersky.com\n"
"s13.upd.kaspersky.com\n"
"s14.upd.kaspersky.com\n"
"s15.upd.kaspersky.com\n"
"s16.upd.kaspersky.com\n"
"s17.upd.kaspersky.com\n"
"s18.upd.kaspersky.com\n"
"s19.upd.kaspersky.com\n"
"p00.upd.kaspersky.com\n"
"p01.upd.kaspersky.com\n"
"p02.upd.kaspersky.com\n"
"p03.upd.kaspersky.com\n"
"p04.upd.kaspersky.com\n"
"p05.upd.kaspersky.com\n"
"p06.upd.kaspersky.com\n"
"p07.upd.kaspersky.com\n"
"p08.upd.kaspersky.com\n"
"p09.upd.kaspersky.com\n"
"p10.upd.kaspersky.com\n"
"p11.upd.kaspersky.com\n"
"p12.upd.kaspersky.com\n"
"p13.upd.kaspersky.com\n"
"p14.upd.kaspersky.com\n"
"p15.upd.kaspersky.com\n"
"p16.upd.kaspersky.com\n"
"p17.upd.kaspersky.com\n"
"p18.upd.kaspersky.com\n"
"p19.upd.kaspersky.com\n"
"downloads.upd.kaspersky.com\n"
"crl.kaspersky.com\n"
"ocsp.kaspersky.com\n"
"downloads.kaspersky-labs.com\n"
"downloads0.kaspersky-labs.com\n"
"downloads1.kaspersky-labs.com\n"
"downloads2.kaspersky-labs.com\n"
"downloads3.kaspersky-labs.com\n"
"downloads4.kaspersky-labs.com\n"
"downloads5.kaspersky-labs.com\n"
"downloads6.kaspersky-labs.com\n"
"downloads7.kaspersky-labs.com\n"
"downloads8.kaspersky-labs.com\n"
"downloads9.kaspersky-labs.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")