$re = '/^After=(.*?)?(?:netfilter-persistent\.service)?(.*?)?$/m';
$str = 'After=network-online.target docker.socket firewalld.service netfilter-persistent.service';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);