#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{4}-\d{2}-\d{2} \d{2}:\d{2}).*(\bStarting\b)(?:\R\1.+\2)+"
Local $sString = "2019-10-31 05:49:52.416 +10:00 [1] - Starting" & @CRLF & _
"2019-10-31 05:49:53.416 +10:00 [1] - Starting" & @CRLF & _
"2019-10-31 05:49:53.416 +10:00 [1] - Starting" & @CRLF & _
"2019-10-31 05:49:53.416 +10:00 [1] - Starting" & @CRLF & _
"2019-10-31 05:49:53.416 +10:00 [1] - Starting" & @CRLF & _
"2019-10-31 05:49:53.416 +10:00 [1] - Starting" & @CRLF & _
"2019-10-31 06:53:58.416 +10:00 [1] - Starting"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")