re = /^(.*)(?=.*?\|.*\1)/m
str = 'iballer|balling
baller|balling
baller|snowballing
aller|balling
motor|motoring
zebra|balling
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end