const regex = /^(https?:|)\/\/(?:[^\/]+?\.)(adform|adformdsp)\.(com|net|local)(\/|$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:|)\\\/\\\/(?:[^\\\/]+?\\.)(adform|adformdsp)\\.(com|net|local)(\\\/|$)', '')
const str = `https://randywestergren.com\\iframe-buster-poc.js?test.adform.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}