$re = '/^(?!\d+$)[a-z]*\d[a-z\d]*$/mi';
$str = 'a123
1a23
abc
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);