package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+(\((?:[^()]++|(?1))*\))?`)
var str = `xyz(text1,(text2,text3)),asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}