// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^.*\.(.*\.[a-z]{0,3})$").unwrap();
let string = "^((?!.*server.*).)*$
am.iqos.com
Exclusive sales - iqos.cz
testdriveiqos.ru
ae.iqos.com
www.iqos.com
al.iqos.com
am.iqos.com
at.iqos.com
ba.iqos.com
bezdymu.pl
bg.iqos.com
boiler iqos.com
ca.iqos.com
calculate.iqosclub.co.uk
campanie-iqos.ro
ch.iqos.com
club.iqos.ro
club.it.iqos.com
co.iqos.com
companion.iqos.co.uk
comparteelcambio.com
conoce-iqos.com
conoceiqos.com
cr.iqosclub.com
cvspickup.com
cy.iqos.com
cz.club.iqos.com
cz.iqos.com
darwin.md
DCE 2.
DCE2 - iqos.com
DCE2 - veev-vape.com
de.iqos.com
discover.iqos.gr
discoveriqos.com
dk.iqos.com
do.iqos.com
ec.myiqos.com
ee.iqos.com
enqueteiqos.com
es.iqos.com
essayeriqos.com
facturi.iqos.ro
Faramentol.ro
fastdelivery.sto
foodhouse.md
futurosinhumo.com
ganaconpmi.com
ge.iqos.com
getinfo.kr
gr.iqos.com
gt.iqos.com
heatnotburn.ro
heatnotburn.se
helloiqos.ro
hk.iqos.com
hr.iqos.com
hu.iqos.com
ic.pmiopen.com
il.iqos.com
intelege.iqos.ro
iqommunity.ro
iqos-care.nl
iqos-coach.com
iqos-on.ro
iqos-partner.ch
iqos.by
iqos.com
iqos.com (raw excl.
iqos.com.ar
iqos.com.co
iqos.com.cw
iqos.com.ua
iqos.id
iqos.lv
iqos.ro
iqos.ro v1.
iqos.ru
iqos.ru and shop.iqos.ru (Production) - Consolidated - Deprecated after 2018.11.
iqos1year.com
iqos3.es
iqos3duo.es
iqosandco.es
iqosasia.com
iqosclub.cz
iqosclub.sk
iqosclubcanarias.com
iqoscr.com
iqosempfehlen.at
iqosexpert.ch
iqosinfo.at
iqositalia.it
iqosjetzt.com
iqosnc.com
iqosphere.jp
iqosplus.de
iqospointdevente.com
iqosprobieren.at
iqosregistrieren.at
iqosrent.nl
iqossvc.kr
iqostestdrive.ru
iqostesten.at
iqosveda.cz
iqosveda.sk
iqoswechseln.at
irefer.co.iqos.com
irefer.gt.iqos.com
irefer.my.iqos.com
it.iqos-boutique.com
it.iqos.com
it.veev-vape.com
jo.iqos.com
jp.iqos.com
kontaktai.iqos.lt
kr.iqos.com
kw.iqos.com
kz.iqos.com
lb.iqos.com
lil.iqos.ru
line.iqosphere.jp
lt.iqos.com
malaysia.iqos.com
mc.myiqos.com
md.iqos.com
me.iqos.com
menthol-ban-retail.co.uk
miasesoriqos.com
mk.iqos.com
mx.iqos.com
my.iqos.com
nazareth.iqos.co.il
newcreations.kr
nl.iqos.com
nokemuhara.jp
nuevoiqos3.es
nz.iqos.com
ocsg.chat.iqos.jp
offer.jp.iqos.com
openinsieme.com
pe.myiqos.com
pl.iqos.com
pmi.23video.com
probar-iqos.com
prohibicionmentolado2020.es
proibicao-mentol2020.pt
promisiunea.iqos.ro
provaiqos.it
pruebaiqos.es
ps.iqos.com
pt.iqos.com
qreator.ro
quiz.sogo-wp.com
re.iqos.com
referidos.iqos.com.co
referiqos.com
referiqosmy.com
register.iqos.id
rs.club.iqos.com
rs.iqos.com
sa.iqos.com
sahmatlafumat.iqos.ro
se.iqos.com
sg.myiqos.com
shareiqos.ch
shop.iqos.ru (Production) - Deprecated after 2018.11.
shop.iqos.ru (raw) - Deprecated after 2018.11.
si.iqos.com
sk.club.iqos.com
sk.iqos.com
smokefreeupdates.co.il
sms.sogo-wp.com
sogo-wp.com
stores.heattobacco.de
systemiqos.pl
teigaku.jp.iqos.com
testeiqos.at
testiqos.ch
testirajiqos.rs
timeforchanges.ch
tobacco-roll.co.il
tr.myiqos.com
trans.sogo-wp.com
tryiqos.ch
tryiqos.kr
tryiqos.ru
uk.iqos.com
uk.veev-vape.com
unsmoke.de
vn.iqos.com
www.iqos.com
www.iqosclub.ch
www.mystartapp.org
www.ordenar-unidades.com
Yext - de.iqos.com
yourdecision.ro
za.iqos.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}