re = /[a-z0-9]+((\.|_|__|-+)[a-z0-9]+)*(\/[a-z0-9]+((\.|_|__|-+)[a-z0-9]+)*)*/m
str = 'foo--bar--qux'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end