import Foundation
let pattern = #"(?P<event_message>An account was successfully logged on.)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:\s+(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+Logon Type:\s+(?P<logon_type>.*?)\s+(?:Impersonation Level:\s+(?P<impersonation_level>.*?)\s+)?New Logon:\s+Security ID:\s+(?P<security_id>.*?)\s+Account Name:\s+(?P<logon_account_name>.*?)\s+Account Domain:\s*(?P<logon_account_domain>.*?)\s+Logon ID:\s+(?P<session_id>.*?)\s+Logon GUID:\s+(?P<logon_guid>.*?)\s+Process Information:\s+Process ID:\s+(?P<process_id>.*?)\s+Process Name:\s+(?P<process_name>.*?)\s+Network Information:\s+Workstation Name:\s+(?P<workstation_name>.*?)\s*Source Network Address:\s+(?P<src_addr>\S+)\s+Source Port:\s+(?P<src_port>.*?)\s+Detailed Authentication Information:\s+Logon Process:\s+(?P<logon_process>.*?)\s+Authentication Package:\s+(?P<auth_package>\S+)\s+Transited Services:\s+(?P<trans_serv>.*?)\s+Package Name \S+\s+\S+\s+(?P<package_name>.*?)\s+Key Length:\s+(?P<key_length>.*?)\s+(?P<event_details>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"An account was successfully logged on. Subject: Security ID: S-1-5-18 Account Name: WIN2K12-TEST$ Account Domain: WORKGROUP Logon ID: 0x3E7 Logon Type: 10 Impersonation Level: Impersonation New Logon: Security ID: S-1-5-21-427599307-2332042502-845149634-500 Account Name: Administrator Account Domain: WIN2K12-TEST Logon ID: 0xE45F2D Logon GUID: {00000000-0000-0000-0000-000000000000} Process Information: Process ID: 0x538 Process Name: C:\\Windows\\System32\\winlogon.exe Network Information: Workstation Name: WIN2K12-TEST Source Network Address: 1.1.1.1 Source Port: 0 Detailed Authentication Information: Logon Process: User32 Authentication Package: Negotiate Transited Services: - Package Name (NTLM only): - Key Length: 0 This event is generated when a logon session is created. It is generated on the computer that was accessed. The subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe. The logon type field indicates the kind of logon that occurred. The most common types are 2 (interactive) and 3 (network). The New Logon fields indicate the account for whom the new logon was created, i.e. the account that was logged on. The network fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases. The impersonation level field indicates the extent to which a process in the logon session can impersonate. The authentication information fields provide detailed information about this specific logon request. - Logon GUID is a unique identifier that can be used to correlate this event with a KDC event. - Transited services indicate which intermediate services have participated in this logon request. - Package name indicates which sub-protocol was used among the NTLM protocols. - Key length indicates the length of the generated session key. This will be 0 if no session key was requested."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)