re = /<+[^\s<](?:[^<>]*[^\s<>])?>+/m
str = 'a <a bc> de
a <<a bc>> de
a <a bc> >de
a <<a bc> de
a <>a bc> de
a < a bc> de
a <a bc > de
a <<a bc >> de
a <a bc >> de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end