re = /\{([^}]+)\(([^)]+)\)\}/
str = 'Invoice Date: {InvoiceDate(dd.mm.YYYY)}
Inoice Number: {InvoiceNumber}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end