$re = '/([a-zA-Z0-9.][a-zA-Z0-9.\- ]*[a-zA-Z0-9.\-])/';
$str = '-- /\\ 11.5
- /\\ 11.5
x-small
-- x-small
us 8.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);