$re = '/(?:\w+\s+){1,2}(?=inner|outer join)|(?<=inner join)(?:\s+\w+){1,2}|(?<=outer join)(?:\s+\w+){1,2}/m';
$str = 'table1 t1 inner join table2 t2 outer join table3
-------------
table1 t1 inner join table2 t2 outer join table3 t3 inner join table2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);