using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0416|0426|0412|0414|0424)[0-9]{7}";
string input = @"04125187034
04245098952
04262545797
04160253340
04145752260";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}