re = /(?=(\(\d+?\)[a-z]\(\d+?\)|[a-z]\(\d+?\)|\(\d+?\)[a-z]))/m
str = 'a(1)a(2)a(1)a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end