$re = '/\b(?![A-Z]*ABCD)[A-Z]{3,}\b/m';
$str = 'JT
JON
JACK
ABCD
TESTABCDTEST
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);