re = /^[0-9]{2}\.([0-9]{1,2})\.([0-9]{1,2})\.(\d)$/m
str = '21.02.28.1
21.02.28.1
patate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end