$re = '/ABC(?=\${0,4}\d)(?=[$\d]{5}\$)(\$*\d+)\$!@/m';
$str = 'ABC $$$$ 1 $!@
Match:
ABC$$$$1$!@
ABC$$$12$!@
ABC$$123$!@
ABC$1234$!@
ABC12345$!@
ABC$$$$$$1$!@
No Match:
ABC$$123456789$!@
ABC1$2$34$!@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);