package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:<.*?)(:.*?:)(?:.+?>)`)
var str = `:fra: :fra: <:fra:12312312> <a:fra:!232131> :fra::fra:
Some text:fra: Hello:fra::fra::fra: :fra:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}