# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:line(\d+)\R)?(\d{2}(?::\d{2}){2}\.\d{2,3})\s*-->\s*(\d{2}(?::\d{2}){2}\.\d{2,3})\R((?:[^\r\n]|\r?\n[^\r\n])*)(?:\r?\n\r?\n|$)"
test_str = ("WEBVTT FILE\n\n"
"line1\n"
"00:00:00.000 --> 00:00:10.000\n"
"‘Stuff’\n\n"
"line2\n"
"00:00:10.000 --> 00:00:20.000\n"
"Other stuff\n"
"Example with 2 lines\n\n"
"line3\n"
"00:00:20.00 --> 00:00:30.000\n"
"Example with only 2 digits in milliseconds\n\n"
"line4\n"
"00:00:30.000 --> 00:00:40.000\n"
"Different stuff\n\n"
"00:00:40.000 --> 00:00:50.000\n"
"Example without a head line")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.