package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^=]+=([^=]*[M][^=]*)$`)
var str = `M=D-M`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}