using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^「(?P<busname>[一-龯]\d{1,2})\s(?P<destination>[一-龯]+)行き・(?P<boardedat>[一-龯]+)」";
string input = @"「渋11 渋谷駅行き・駒沢大学駅前」でタッチしました。";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}